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TORAIZ AS-1 SoundEditor

1. Introduction

Welcome to SoundEditor, a full-featured Editor and Sound Development tool for the
Pioneer DJ TORAIZ AS-1 ANALOG SYNTHESIZER.

SoundEditor LE can be used to perform the operations listed below.

- Adjust program parameters and edit sequence patterns

- Write programs to AS-1 and save/load programs to computer
- Replace programs and edit banks

- Send banks to AS-1 and save/load banks to computer

- Change AS-1 GLOBAL SETTING

We hope you enjoy using SoundEditor for your AS-1 ANALOG SYNTHESIZER!
1.1 About This Manual

This manual is a simple manual for the SoundEditor LE version.
As for the details, please check the YouTube video.

Throughout the manual, we will use screenshots of the SoundEditor application for
illustrative purposes. These screenshots are based on SoundEditor for PCs, although
you should see similar views if you are using SoundEditor on a Mac. When any
significant discrepancy in the appearance or operation of SoundEditor occurs
between theMac and PC platforms, we will describe the differences.

1.2 Support

Online support for this product is available at:
http://www.soundtower.com/toraiz
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2. Starting Up

2.1 AS-1 Setup

Before establishing a connection between SoundEditor and the AS-1,
configure the AS-1 GLOBAL SETTING as shown below.

Proper operation may not be possible without these settings.

GLOBAL SETTING

8 MIDI Param Send : NRPN

9 MIDI Param Rcv : NRPN
10 MIDI Control Enble : On
11 MIDI Sysex Cable : USB or MIDI (depending on the connection)
12 MIDI Out Select : USB or MIDI (depending on the connection)
13 MIDI Out/Thru : Out

2.2 Getting Connected

Connect the AS-1 to your computer by the USB cable or the MIDI interface.

If you are using the MIDI interface, it must connect with both MIDI In and MIDI Out
connectors.

After making the connections between the AS-1 and your computer,
power up the AS-1 and launch SoundEditor.

2.3 MIDI Setup

If you are working with SoundEditor for the first time, you will need to configure
the program for MIDI communication with the AS-1 hardware.

SoundEditor will remember the configuration until you change it.
Click on the MIDI menu and select [MIDI Setup].

File Edit |MIDI Parameters Options Help
' MIDI Setup Ctri+M

Receive Current Program Ctri+R
Transmit Current Program Crl+T

Receive Bank

Transmit Bank

The MIDI Setup window will appear, displaying the available MIDI Port connections
on your computer.
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In the MIDI Setup window, select the MIDI IN and OUT ports o which the AS-1 is
connected. Set the MIDI Channel to match the MIDI channel on the AS-1.

Once the proper ports and MIDI channel are selected, the screen below should appear.

B3 MIDI Setup = =
Toraiz A5-1 ON-LINE

MIDI PORTS | MIDIIN - KEYBOARD CONTROLLER | USB DRIVER SETTINGS

MIDIIN PORT MIDI QUT PORT

1 Toraiz AS-1 Microsoft GS Wavetable Synth
2 loopMIDI Port Toraiz A5-1

3 loopMIDI Port

P =

Impaortant : In arder for the editor to contral the Taraiz AS-1 correctly set Global settings as follows:

To control the Toraiz AS-1 in real-time: For data communication:
MIDI Controller Enable: ON MIDI Sysex Enable: ON
MIDI Parameter Send: NRPMN MIDI Sysex Cable: USE or MIDI (depending on the connection)

MIDI Parameter Receive:: MRPM

MIDI Global Channel: | All Channels = [ pon | [ ok |

2.4 Getting Banks from the AS-1

When using SoundEditor for the first time, we recommend that the bank data in
SoundEditor matches that of the AS-1. Click on the MIDI menu, select [Receive Bank],
and specify [All User Banks] to get all user bank programs from the AS-1.

File Edit Parameters Options Help

MIDI Setup Ctri+M

Half Note

Receive Current Program Ctri+R
Transmit Current Program Ctri+T

Receive Bank Program Bank U-1
Transmit Bank Program Bank U-2
Program Bank U-3
USER 2
U-2P 01 Program Bank U-4

LD JustifiedAn« Program Bank U-5

U-2P02 All User Banks [

So Good LD Cast¢

Program Bank F-1

BA 3:03 AM D Thick AS-1 Program Bank F-2
Res Bass program Bank F-3
U-2P 04

BA Shimmertril

Program Bank F-4

Program Bank F-5
U-2P 05
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3. Editing Program

You can edit the program that is shown in the Program Name Display.

A different program can be selected by using the PROGRAM knob on the AS-1
or in the Banks window in SoundEditor.

3.1 Adjusting Parameters
Select [VOICE] to display the Parameters window.

Use the knobs, buttons, checkboxes, and other controls to adjust the parameters.

U-5 P99 OMN-LINE
It's a Prophet...!

| BANKS SEQUENCER || GLOBAL

In the Controls Window, you can change the ADSR parameters for AMPLIFIER ENVELOPE or
FILTER ENVELOPE by using the ADSR knobs or by grabbing and dragging the associated
parameter handle in the envelope display as shown below:

FILTER ENVELOPE

34 70

SUSTAIM RELEASE

AMPLIFIER ENVELOPE

108 49 oo

DECAY SUSTAIN RELEASE
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In [Preferences] in the File menu, you can change how the knob controls and
mouse wheel behave by adjusting the values.

Edit MIDI Parameters Options Help

- ~
B preferences ﬁ

Load All Data
Save All Data Editor Controls
Load Sysex File
Save All Data as SySex file )
Mouse wheel value adjustment: Scroll Down to Increase values -
Load Program Bank To . Knob value adjustments -
Save Program Bank 3
Linear - vertical motion

Load Single Program Ctri+0 Linear -vertical/horizontal
Save Single Program Ctri+5
Preferences Ctri+’ |
Quit Ctr+Q

e - - QK

L u Vi
FREGQUEMNCY FINE PE PLULBE .

After a parameter is changed, you can select [Undo] or [Redo] in the Edit menu.

File | Edit | MIDI Parameters Options Help

Paste Program Ctrl+Vv
Copy Program Ctrl+C
Write Program Chrl+W
Undo AMOUNT Ctrl+2
Redo CUTOFF Ctrl+Y

Copy Sequencer
Paste Seguencer

Rename Program Crl+M

Initialize Program Ctrl+I

3.2 Editing Sequencer

Select [SEQUENCER] to display the Sequencer window.

U-5 P 99 ON-LINE
It's a Prophet...!

| BaNKsS || voICE || SEQUENCER || GLOBAL
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a) Note
b) Velocity
c) Tie

d) Slew
e) Length

Sequencer Length:

: Right-click to insert a note. Double-click to delete a note (insert a rest).
: Click and drag to adjust the velocity. When set to 0, a rest is added.
: Tie is set when the right edge of a note is dragged,

or when the checkbox is set to ON.

: Slew is set when the checkbox is set to ON.
: Slide the bar left or right to change the number of sequencer steps.

You can click the Edit menu and select [Copy Sequencer] to copy the sequence pattern
of the current program. Select [Paste Sequencer] to paste it into another program.

After a sequence pattern is changed, you can select [Undo] or [Redo] in the Edit menu.

File | Edit | MIDI Parameters Options Help
Paste Program ctrl+v
Copy Program Ctrl+C
Write Program Chrl+W

Undo Step 2 note insert ctrl+Z
Redo Step 1 Mote Chrl+Y

Copy Sequencer

Paste Sequencer

Rename Program

Initialize Program
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3.3 Writing Program to the AS-1

After changing the parameters or sequence pattern, make sure to select
[Write Program] in the Edit menu to save the changes to the AS-1. This is
the equivalent to the WRITE function (SHIFT+GLOBAL) on the AS-1.

Please note that if you select a different program without performing [Write Program],
the changes will be discarded.

File | Edit | MIDI Parameters Options Help

Paste Program Ctri+v
Copy Program Ctri+C
Write Program Chrl+W
Undo Step 2 note insert Ctri+Z
Redo Step 1 Mote Cri+Y

Copy Sequencer
Paste Sequencer

Rename Program Ctrl+MN

Initialize Program Ctrl+1

3.4 Saving Program to the Computer

To save an edited program to the computer, click the File menu and select
[Save Single Program]. The program is saved with the "*.tas1l_program" file extension.

3.5 Loading Program from the Computer

To load a program to the computer, click the File menu and select
[Load Single Program]. You can also perform this operation to replace a program.

When loading, use files with the "*.tas1_program" extension.

File | Edit MIDI Parameters Options Help
Load All Data
Save All Data

Load Sysex File
Save All Data as SySex file

Load Program Bank To »
Save Program Bank »
Load Single Program Ctrl+0 |
Save Single Program Ctrl+5 EE
Preferences Cirl+'
Quit Ctl+Q

c2 TRI

FREQUENCY SHAPE PULEH
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4. Editing Banks

Select [BANKS] to display the Banks window.

U-5 P 99 ON-LINE
It's a Prophet...!

WOICE |E-EC[I_IENCEF‘. GLOBAL

4.1 Copying Program between Banks

USER 1 USER 2
U-1P 01 U-2P01
BAPro-One LD JustifiedAncient
! Bright Lead
U-1P 02

U-1r03
BA 3:03 AM

Res Bass : Bright Lead
U-1P 04 U-2 P04
LD Empty House BA Shimmertrill

You can use any of the methods below to replace a program with another program
from a different bank.

a) Select [Copy Program] in the Edit menu to copy a program, then select
[Paste Program] to paste it over another program.

b) Select [Load Single Program] in the File menu to overwrite another program.

¢) Right-click on a program and select [Copy ****] to copy it, then select
[Paste ****] to paste it over another program.

File MIDI Parameters Options Hel Flle| Edit MIDI Parameters Options Help
Load All Data

Save All Data

Paste Program Ctri+V
Copy Program Ctri+C
Load Sysex File

Save all Data as SySex file

Write Program Ctri+wW

Can't Undo Ctri+Z

Can't Redo Ctr+Y Load Program Bank To v
Save Program Bank b
Rename Program Ctri+N
Load Single Program Ctrl+0
Initialize Program Ctrl+I EraElin -
. Save Single Program Ctrl+5 E b
Preferences Ctri+' E

10
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USER 1

U-1P 01

BAPro-One ) _lyctifisdAncier A S C
Copy LD JustifiedAncient

U-1P02
LD Feels So Good Paste BA 3:03 AM
Rename LD JustifiedAncient

U-1P03
BA 3:03 AM Save LD JustifiedAncient
Res Bass )
U-1P 04 Load Program

) Empty House
R LAy Initialize
U-1P 05
BADerpy Donk

4.2 Transmitting Banks to the AS-1

Click the MIDI menu and select [Transmit Bank] to send all programs in the specified
SoundEditor bank to the AS-1. Please note that when [Transmit Bank] is performed,
all programs in the specified AS-1 bank are overwritten.

File Edit | MIDI | Parameters Options Help
MIDI Setup Ctrl+M

. 118 Triplat
Receive Current Program Ctrl+R i
* 118 Ful

Transmit Current Program

Receive Bank /8 Swing

Transmit Bank Program Bank U-1

Program Bank U-2

USER 2

U-1P01 U-2P01
BAPro-One LD JustifiedAn Program Bank U-4

Program Bank U-3 N

UAP 02 Program Bank -5

All User Banks

U-1P03 U-2P0
BA 3:03 AM LD Thi
Res Bass Program Bank F-2
U-1P 04 U-E_F‘ _EI4 ) Program Bank F-3
LD Empty House BA Shimmertril

Program Bank F-1

Program Bank F-4

U-1P 05 U-2P05 Program Bank F-3
BADerpy Donk BA Street Pulse

4.3 Receiving Banks from the AS-1

When you click the MIDI menu and select [Receive Bank], SoundEditor receives all
programs from the specified AS-1 bank. Please note that when [Receive Bank]
is performed, all programs in the currently selected SoundEditor bank are overwritten.

11



TORAIZ AS-1 SoundEditor

File Edit | MIDI | Parameters Options Help

MIDI Setup Ctrl+M \CK
. Half Mote
Receive Current Program Ctri+R

Querter Mote

Transmit Current Program CErl+T 1/8 D

Receive Bank Program Bank U-1

Transmit Bank Program Bank U-2
Program Bank U-3

USER 1 USER 2
U-1P M U2P01 Program Bank U-4

BAPro-One LD JustifiedAnt Program Bank U-5

U-1P02 2 All User Banks
LD Fee )
Program Bank F-1
U-1P03
BA 3:03 AM Program Bank F-2
Res Bass Program Bank F-3
U-1P04 2P 0 _ Program Bank F-4
LD Empty House A
Program Bank F-5

U-1P05

4.4 Saving Banks to the Computer

- To save the data of a specific user bank to the computer,
perform the following operation:

a) Select [Save Program Bank] in the File menu and specify which bank to save.
The bank data is saved with the "*.tas1l_bank" file extension.

- To save all user bank data to the computer, perform either one of the two
operations below:

b) Select [Save All Data] in the File menu to save all user banks.
The bank data is saved with the "*.tas1_synth" file extension.

c) Select [Save All Data as SySex file] in the File menu to save all user banks.
The bank data is saved with the "*.syx" file extension.

For details about "*.syx" files, see "4.5 Loading Banks from the Computer".

Edit MIDI Parameters Options Help
b Load All Data CLOCK
Save All Data Half Mate
‘ Quartsr Mote
Load Sysex File /8D
C Save All Data as SySex file
Load Program Bank To 3
a Save Program Bank v Program Bank U1
Load Single Program Ctrl+0 REE DL L2
Save Single Program Ctrl+5 Rle L e
Program Bank U4
Preferences Cerl+ Program Bank US
Quit Ctrl+Q

LD Thick AS-1

BA3:03 AM
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4.5 Loading Banks from the Computer

- To load bank data from the computer to a specific user bank, perform either
one of the two operations below.

a) Select [Load Program Bank to] in the File menu, and specify the bank
in which to load the bank data.

When loading, use files with the "*.tas1l_bank" extension.
b) Select [Load Sysex File] in the File menu to load a "*.syx" file and
launch the Bank Loader. Specify the bank data that you want to load,

and the user bank in which to load it.

- To load bank data from the computer to all user banks, perform either one of
the two operations below.

c) Select [Load All Data] in the File menu to load all user banks.
When loading, use files with the "*.tas1_synth" extension.

d) Select [Load Sysex File] in the File menu to load a "*.syx" file and
launch the Bank Loader. Select [Load All] to load all user banks.

File| Edit MIDI Parameters Options Help Bank Loader 2
Load All Data Bank data:  Bank contents: Load to:
Save All Data Mo, Program Category

= Eank -1 ' Eank -1
Load Sysex File ;
__ : Bank -3 Bank -3
Save All Data as SySex fils I @ Ful
Load Program Bank To 3 Frogram Bank U-1 w
Save Program Bank 3 Program Bank U-2 L
-
. = Program Bank U-3
Load Single Program Ctrl+0 09 = o

Save Single Progiam ctrl+5 Program Bank U-4
Program Bank U-5
Preferences Ctrls

Quit Cirl+Q
LDAnalagHouseOfg

[Loadan |

13
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5. Additional information

5.1 Troubleshooting

- If the AS-1 and SoundEditor are connected but do not operate properly, then check
that the AS-1 GLOBAL SETTING is configured as described in "2.1 AS-1 Setup".

- If the connection between the AS-1 and SoundEditor is interrupted due to reasons
such as a cable being plugged or unplugged, then:

Select [MIDI Setup] in the MIDI menu, and specify the AS-1 again.
You can check the connection status in the Program Name Display.

U-5P 99

It's a Prophet...!

U-5P 99

It's a Prophet...!

Synth

| BANKS || VOICE || SEQUENCER || GLOBAL

| BANKS || VOICE || SEQUENCER || GLOBAL

5.2 File Extensions

SoundEditor uses the following file extensions to specify AS-1 data:

Single Program Data : [*.tasl_program]
User Bank Data (Single Banks) : [*.tasl_bank]

All Data (User Banks 1~5) : [*.tasl_synth]
All Data (User Banks 1~5 or Single Banks) : [*.syx]

14
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5.3 MIDI Setup for use with another MIDI Sequencer (Windows PC
When using SoundEditor with a MIDI sequencer (ProTools, Cubase, Ableton Live, etc.)
on a Windows PC, a virtual MIDI driver is required. Use a third-party virtual MIDI driver
for the connection. (For example, use Loop MIDI, MIDI Yoke, etc.)

We recommend the MIDI connection shown below.

TORAIZ AS-1 SoundEditor Virtual MIDI MIDI
OUT (mummlp |N ouT N Driver oo — INSequencer
IN

Below is an excample of a connection procedure.
1 Launch the virtual MIDI driver on the computer.
2 Turn ON the AS-1.

3 Launch SoundEditor and check that the connection status is ON-LINE.

U-5 P 95

It's a Prophet...!

| BANKS || VOICE || SEQUENCER || GLOBAL

4 Launch the MIDI sequencer.

5 In SoundEditor, click the MIDI menu, select [MIDI Setup],
and configure the MIDI PORTS settings below.

MIDI IN PORT 1 AS-1
MIDI OUT PORT : Virtual MIDI port
B3 MIDI Setup = 2

Mot Connected

MIDI PORTS | MIDIIN - KEVEOARD CONTROLLER | USE DRIVER SETTINGS

[ MIDIIN PORT

|| miDrout porT
|1 Toraiz AS-1 1  Microsoft G5 Wavetable Synth
£ loopMILL Port 2 Taoraiz A5-1

|2 loopMIDI Port

Important : In order for the editor to control the Toraiz AS-1 correctly set Global settings as follows:

To control the Toraiz AS-1 in real-time: For data communication:
MIDI Controller Enable:: OMN MIDI Sysex Enable: ON
MIDI Parameter Send: NRPN MIDI Sysex Cable: USE or MIDI (depending on the connection)

MIDI Parameter Receive:: NRPN

MIDI Global Channel: | All Channels = [ Pon | [ok ]

15
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Although the SoundEditor connection status is displayed as OFF-LINE,
you can continue configuring the settings.

U-5 P 99

It's a Prophet...!

BANKS || WVOICE SEQUENCER || GLOBAL WOICE SEQUENCER || GLOBAL

5 Configure the MIDI IN/OUT settings below for the MIDI sequencer.

MIDI IN PORT : Virtual MIDI port
MIDI OUT PORT 1 AS-1

As an example, when using with Ableton Live:
- Configure the MIDI settings in Preferences.
If an output listed under MIDI Ports is displayed in orange, turn the Sync

setting OFF and back ON to refresh the connection status.

- Configure the MIDI IN/OUT settings of the MIDI track
as shown on the right.

MIDI From : Virtual MIDI Port
MIDI To : TORAIZ AS-1
Arm : ON

16



